2015年4月30日木曜日

DELL XPS M1330 に Windows 10 TP をインストール

先日 XPS M1330 のメモリを 4GB に増設して Vista が快適に動作するようになりました。すると欲が出てきて、7 月末に発売と言われている Windows 10 も使えないだろうか?などと思い始めたり。そこで Windows 10 のシステム要件を調べてみました。

システム要件
  • CPU: 1 GHz 以上
  • メモリ: 1 GB (32 ビット) または 2 GB (64 ビット)
  • ハード ディスクの空き容量: 16 GB
  • グラフィックス カード: Microsoft DirectX 9 グラフィックス デバイス (WDDM ドライバー付き)
  • Microsoft アカウントとインターネット アクセス

これを見ると XPS M1330 でも行けそうな気がします。

とりあえず Windows 10 Technical Preview 64bit をインストールしてみることにしました。

結果




インストールできて普通に使えました。

むしろあっけなく動いてびっくりです(^_^; インストール時にエラーが出るようなこともありませんでした。評価版なのでおかしなところはいくつかあるものの、Vista と比べても動作は軽快で起動も速いです。Core 2 Duo でも大丈夫そうですね。このスペックの PC でも普通に使えるとは驚きです。心配だったドライバはほとんどのデバイスで最初からインストールされていました。全てのデバイスの動作を確認したわけではないですが、画面表示、音声、指紋認証などは正常に機能しているようです。

唯一 Ricoh の Memory Stick Controller のドライバだけは入っておらず、Dell のサイトから Vista 用のドライバをダウンロードしてインストールしました。他には Windows 10 の汎用ドライバでは Touchpad のスクロール機能が利かなかったり、音は出るもののサウンドデバイスが実際とは異なるデバイスとして認識されるなど、若干の問題はありましたが、Vista や Win 7 のドライバをインストールすることで解決できました。

インストールしたドライバおよびアプリ

正式版でどうなるか分かりませんが、大きな変更がない限りは XPS M1330 でも Windows 10 を使えそうな印象です。

*追記
製品版の Windows 10 も問題なく動作しました。必要なドライバをインストールして、いくつかの設定を変更すれば正常に使用できます。

関連記事 : DELL XPS M1330 の Windows10 インストール手順

2015年4月29日水曜日

DELL XPS M1330 のメモリ増設 - 2GB から 4GB へ

DELL XPS M1330 は Vista マシンですが、ネットを見たり文書を作る程度ならまだ十分使えるノート PC なので、今でもよく使っています。しかし最近、頻繁にハードディスクにアクセスして動作が固まったり遅くなることが増えてきました。

普段使っているブラウザの Firefox はメモリ消費が結構多いらしく、使っているとメモリ不足に陥ってスワップが発生しているようです。動作が遅くなるのは困るし、ハードディスクへの負荷から故障が早まるのも困るので、スワップによるディスクアクセスを減らそうと思い、今更ながらメモリを 2GB から最大量の 4GB に交換増設することにしました。

増設用のメモリ


XPS M1330 に対応するメモリの規格は PC2-5300 DDR2 SDRAM 667MHz です。2GB 2 枚組のものを購入しました。


メモリ交換の手順


交換作業は PC 本体裏側のネジを数本外してカバーを開け、元々付いているメモリ 2 枚を取り外して新しいものに付け替えるだけです。カバーを開けるだけでメモリスロットが見えるので、交換は割と簡単にできました。交換方法の詳しい説明はマニュアルの p134 - にあります。

Dell の公式マニュアル :
Dell XPS M1330 オーナーズマニュアル

交換が終わって電源を入れてみると、普段の起動とは少し違って画面が黒いままの状態がしばらく続き、 BIOS から先になかなか進みませんでした。多少不安になりましたが、少し待っていると英語で「メモリがインストールされました」という内容の表示が出て再起動され、無事 Windows が起動しました。交換後の初回起動は新しいメモリの認識作業が行われるようです。

メモリ増設の結果


正直なところ、メモリを増やしたくらいでは動作はそれ程変わらないだろうと思っていたのですが、実際は効果抜群でした。ハードディスクへのアクセスが激減して起動直後から動作が軽い!これはすごい。

どうしてもっと早く増設しなかったんだろう…(^^;



メモリサイズは 4GB と認識され、動作もデュアルチャネルになっており、問題はないようです。OS が 32bit なので実際に使えるのは 3.5GB 程度でしたが、それでもメモリ増設の効果は自分の環境では劇的でした。

インストールしているソフトにより多少の違いは出るかもしれませんが、メモリが 2GB では Vista が起動するだけでギリギリに近いらしく、快適に使うには 2GB 以上あった方がいいようです。もしハードディスクが頻繁にカリカリと動いていて遅いなと感じる場合には、メモリの増設をしてみることお勧めします。

また、メモリ増設だけでなく SSD への換装も動作改善に効果があるかもしれません。SSD の価格も徐々に下がってきているようなので、そちらもまた時間のあるときに試してみようかなと思います。

2015年4月7日火曜日

Buffalo ルーターの設定画面が 404 Not Found

自宅の無線 LAN ルーターの調子が悪かったため、AirStation WHR-HP-GN から同じ Buffalo 製の WHR-300HP2 に買い換えました。

自分はそれほど性能を重視しておらず、価格が安いこのモデルを買いましたが、それでも今まで使っていたルーターの 2 倍の通信速度になったので、ファイル共有でのコピーが速くなり、まるでハイエンドの機種を買ったような気分になれました(笑。とにかく無線が繋がればいいという人であれば、不満なく使えるルーターだと思います。

ただ一つ、ルーターの交換で落とし穴がありました。

新しいルーターを設置して設定をしようと思い、http://192.168.11.1/を開くと


404 Not Found

なぜか設定画面が出てこない。

アドレスバーに"192.168.11.1"と打ち込んでページを開いても"192.168.11.1/cgi-bin/cgi?req=twz"と表示され 404 Not Found。

困ったのでネットで調べてみると、原因としてブリッジモードになっている可能性を指摘する書き込みなどを見つけました。しかし自分は最初からルーターのスイッチをルーターモードに切り替えて使っていたので、ブリッジモードの可能性は無し。他には別のブラウザだと設定画面が出たという情報もあったので、普段使っている Firefox ではなく Chrome で開いてみました。すると実にあっさり設定画面が表示されました。

ひとまず目的は達成。

しかし、設定を見るためだけに別のブラウザを使うのも面倒なので、なんとか Firefox で表示できないかなと色々試してみたら、

ブラウザのキャッシュを消せばいいだけのことでした。

前のルーターの設定ページのキャッシュが悪さをしていたみたいです。Buffalo 製ルーターの場合、機種が違っても設定画面の構成が似ており、IP アドレスも同じ (192.168.11.1) なので、新しい機種の設定画面で古い機種のキャッシュが読み込まれてしまい、表示がおかしくなったのだと思います。これにたどり着くまでに、本体を何度も初期化したり IP アドレス変えたりと、1 時間くらい無駄なことをしていました(^^;

ルーターの買い換えでは、以前と同じメーカーの製品を購入することも多いと思うので、このトラブルは割とよく起きていそうな気がします。もし同じような状況になっている場合には、ブラウザのキャッシュの消去をしてみることをおすすめします。